EJERCICIOS RESUELTOS

Diseñar un algoritmo que pida por teclado tres números; si el primero es negativo, debe imprimir el producto de los tres y si no lo es, imprimirá la suma.
Var numero1, numero2, numero3, resultado: numerica
Inicio
    Escribir "Introduce el primer numero"
Leer numero1
Escribir "Introduce el segundo numero"
Leer numero2
Escribir "Introduce el tercer numero"
Leer numero3
Si (numero1<0) Entonces
resultado<-numero1*numero2*numero3
Sino
resultado<-numero1+numero2+numero3
FinSi
Escribir resultado
Fin
Desarrollar un algoritmo que nos calcule el cuadrado de los 9 primeros números naturales (recuerda la estructura desde-hasta)
Var num, res: numerica
Inicio
Desde num<-1 Hasta 9 In 1
res<-num^2
Escribir num "        " res
FinDesde
Fin

Realizar un algoritmo que lea un número por teclado. En caso de que ese número sea 0 o menor que 0, se saldrá del programa imprimiendo antes un mensaje de error. Si es mayor que 0, se deberá calcular su cuadrado y la raiz cuadrada del mismo, visualizando el numero que ha tecleado el usuario y su resultado (“Del numero X, su potencia es X y su raiz X” ). Para calcular la raiz cuadrada se puede usar la función interna RAIZ(X)  o con una potencia de 0,5.
SOLUCIÓN 1
Var numero, potencia, raiz: numerica
Inicio
    Escribir "Introduce un numero"
    Leer numero
    Si (numero>0) Entonces
        potencia<-numero^2
        raiz_cuadrada<-numero^0,5
        Escribir "Su potencia es " potencia "
        Escribir "Su raiz es " raiz_cuadrada
    Sino
        Escribir "Error, introduce un numero mayor que 0"
    FinSi
Fin

SOLUCIÓN 2

Proceso ejercicio_6
   Escribir "Introduce un numero"
   Leer numero
   //si el numero es mayor que 0, calcula la potencia y la raiz
   //sino muestra un mensaje de error y sale del programa
   Si (numero>0) Entonces
       potencia<-numero^2
      raiz_cuadrada<-RAIZ(numero)
       Escribir "Su potencia es " potencia
       Escribir "Su raiz es " raiz_cuadrada
   Sino
       Escribir "Error, introduce un numero mayor que 0"
   FinSi
Fin Proceso



No hay comentarios.:

Publicar un comentario